Imposible d'instaler sur Ubuntu

You have tested TA3D, share your experience /
Vous avez testé TA3D, venez partager votre expérience
Post Reply
rsieuz29
Posts: 6
Joined: Wed Apr 25, 2018 4:01 pm

Imposible d'instaler sur Ubuntu

Post by rsieuz29 » Wed May 22, 2019 4:40 pm

Bonjours à tous, je n’arrive pas a installer TA3D sur Ubuntu. Qui accepterais de m'aider?? :p
En particulier je pence avoir un problème avec SDL_net version 1.2
Plus exactement je suis aller sur ce lien http://www.ta3d.org/linuxdl.php et j'ai recherché toute les dépendences, c'est a dire GNU-GCC, SDL 1.2 ainsi que SDL_image, SDL_mixer et SDL_net (alors ici j'ai eu de grosse dificulté pour trouvé SDL_net version 1.2), GLEW, zlib et FMOD.
Ensuite j'ai appliquer un

Code: Select all

cmake ./
dans le dossier ta3d/src.
Voici ce que ça ma donné!

Code: Select all

sieuzac@sieuzac-Latitude-7480:~/Documents/Compil TA3D/CP8/ta3d/src$ cmake ./
-- The C compiler identification is GNU 5.4.0
-- The CXX compiler identification is GNU 5.4.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- 
-- --- TA3D, Remake of the Total Annihilation engine ---
-- 
-- Version : v0.6.0 (Rev: 1)
--  System : Linux-4.4.0-148-generic (x86_64)
-- 
-- {yuni} -- 
-- {yuni} -- The Yuni Framework
-- {yuni} -- 
-- {yuni} -- Version : v0.1-debug (Rev: 1)
-- {yuni} -- System: Linux-4.4.0-148-generic (x86_64)
-- {yuni} -- Generator : Unix Makefiles
-- {yuni} -- g++ Variant : c++ (Ubuntu 5.4.0-6ubuntu1~16.04.11) 5.4.0 20160609
-- {yuni} -- Folders
-- {yuni} --          Source: /home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/libs/yuni/src
-- {yuni} --      Build into: /home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/libs/yuni/src
-- {yuni} --   Using profile: Yuni's profile for TA3D
-- {yuni} --        found in: /home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/libs/yuni/src/ProfileBuild.cmake
-- {yuni} -- 
-- {yuni} -- Modules
-- {yuni} -- 
-- Performing Test YUNI_HAS_GCC_CPP0X_SUPPORT
-- Performing Test YUNI_HAS_GCC_CPP0X_SUPPORT - Success
-- {yuni} -- :: [Module] Core
-- Looking for pthread.h
-- Looking for pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- {yuni} -- Threading Support: PThreads (-lpthread)
-- Looking for C++ include stdio.h
-- Looking for C++ include stdio.h - found
-- Looking for C++ include string.h
-- Looking for C++ include string.h - found
-- Looking for C++ include time.h
-- Looking for C++ include time.h - found
-- Looking for C++ include assert.h
-- Looking for C++ include assert.h - found
-- Looking for C++ include cassert
-- Looking for C++ include cassert - found
-- Looking for C++ include errno.h
-- Looking for C++ include errno.h - found
-- Looking for C++ include cstddef
-- Looking for C++ include cstddef - found
-- Looking for C++ include climits
-- Looking for C++ include climits - found
-- Looking for C++ include vector
-- Looking for C++ include vector - found
-- Looking for C++ include list
-- Looking for C++ include list - found
-- Looking for C++ include map
-- Looking for C++ include map - found
-- Looking for C++ include algorithm
-- Looking for C++ include algorithm - found
-- Looking for C++ include iostream
-- Looking for C++ include iostream - found
-- Looking for C++ include dirent.h
-- Looking for C++ include dirent.h - found
-- Looking for C++ include stdlib.h
-- Looking for C++ include stdlib.h - found
-- Looking for C++ include unistd.h
-- Looking for C++ include unistd.h - found
-- Looking for C++ include fcntl.h
-- Looking for C++ include fcntl.h - found
-- Looking for C++ include cstdlib
-- Looking for C++ include cstdlib - found
-- Looking for C++ include stdarg.h
-- Looking for C++ include stdarg.h - found
-- Looking for C++ include sys/sendfile.h
-- Looking for C++ include sys/sendfile.h - found
-- Performing Test YUNI_HAS_VA_COPY
-- Performing Test YUNI_HAS_VA_COPY - Success
-- Looking for C++ include sys/types.h
-- Looking for C++ include sys/types.h - found
-- Performing Test YUNI_HAS_INT64_T
-- Performing Test YUNI_HAS_INT64_T - Success
-- Performing Test YUNI_HAS_INT128_T
-- Performing Test YUNI_HAS_INT128_T - Success
-- Performing Test YUNI_HAS_NULLPTR
-- Performing Test YUNI_HAS_NULLPTR - Success
-- Performing Test YUNI_HAS_SYNC_ADD_AND_FETCH
-- Performing Test YUNI_HAS_SYNC_ADD_AND_FETCH - Success
-- Performing Test YUNI_HAS_LONG
-- Performing Test YUNI_HAS_LONG - Failed
-- {yuni} -- :: [Module] Network
-- {yuni} -- 
-- {yuni} -- [yuni-config] Bootstraping
-- {yuni} -- Configuring yuni-config...
-- {yuni} -- (in /home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/libs/yuni/src/tools/yuni-config)
-- The CXX compiler identification is GNU 5.4.0
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- {yuni} -- 
-- {yuni} -- yuni-config
-- {yuni} -- 
-- Performing Test YUNI_HAS_GCC_CPP0X_SUPPORT
-- Performing Test YUNI_HAS_GCC_CPP0X_SUPPORT - Success
-- Configuring done
-- Generating done
-- Build files have been written to: /home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/libs/yuni/src/tools/yuni-config-bootstrap
-- {yuni} -- Compiling yuni-config...
Scanning dependencies of target yuni-config
[  6%] Building CXX object CMakeFiles/yuni-config.dir/home/sieuzac/Documents/Compil_TA3D/CP8/ta3d/src/libs/yuni/src/yuni/core/version/version.cpp.o
c++: error: TA3D/CP8/ta3d/src/libs/yuni/src/tools/yuni-config": Aucun fichier ou dossier de ce type
CMakeFiles/yuni-config.dir/build.make:62 : la recette pour la cible « CMakeFiles/yuni-config.dir/home/sieuzac/Documents/Compil_TA3D/CP8/ta3d/src/libs/yuni/src/yuni/core/version/version.cpp.o » a échouée
make[2]: *** [CMakeFiles/yuni-config.dir/home/sieuzac/Documents/Compil_TA3D/CP8/ta3d/src/libs/yuni/src/yuni/core/version/version.cpp.o] Erreur 1
CMakeFiles/Makefile2:67 : la recette pour la cible « CMakeFiles/yuni-config.dir/all » a échouée
make[1]: *** [CMakeFiles/yuni-config.dir/all] Erreur 2
Makefile:83 : la recette pour la cible « all » a échouée
make: *** [all] Erreur 2
-- Looking for the Yuni Framework - failed ('yuni-config' not found)
CMake Error at CMakeLists.txt:75 (Message):
  The Yuni Framework could not be found.


-- Could NOT find Freetype (missing:  FREETYPE_LIBRARY FREETYPE_INCLUDE_DIRS) 
-- Found SDL: /usr/lib/x86_64-linux-gnu/libSDLmain.a;/usr/lib/x86_64-linux-gnu/libSDL.so;-lpthread (found version "1.2.15") 
-- [sdl] include: /usr/include/SDL
-- [sdl] libs   : /usr/lib/x86_64-linux-gnu/libSDLmain.a;/usr/lib/x86_64-linux-gnu/libSDL.so;-lpthread
CMake Warning (dev) at ta3d/CMakeLists.txt:1 (PROJECT):
  Policy CMP0048 is not set: project() command manages VERSION variables.
  Run "cmake --help-policy CMP0048" for policy details.  Use the cmake_policy
  command to set the policy and suppress this warning.

  The following variable(s) would be set to empty:

    TA3D_VERSION_PATCH
This warning is for project developers.  Use -Wno-dev to suppress it.

-- 
-- --- TA3D ---
-- 
-- Build Configuration: Debug
-- Found SDL_image: /usr/lib/x86_64-linux-gnu/libSDL_image.so (found version "1.2.12") 
-- Found SDL_mixer: /usr/lib/x86_64-linux-gnu/libSDL_mixer.so (found version "1.2.12") 
-- Could NOT find SDL_net (missing:  SDL_NET_LIBRARIES SDL_NET_INCLUDE_DIRS) 
-- [SDL] SDL: TRUE
-- [SDL] SDL_image: TRUE
-- [SDL] SDL_mixer: TRUE
-- [SDL] SDL_net: FALSE
-- [SDL] SMPEG: SMPEG_LIBRARY-NOTFOUND
-- [SDL] Include dir: /usr/include/SDL
-- [SDL] The SDL library: /usr/lib/x86_64-linux-gnu/libSDLmain.a;/usr/lib/x86_64-linux-gnu/libSDL.so;-lpthread
-- [SDL] The SDL_image library: /usr/lib/x86_64-linux-gnu/libSDL_image.so
-- [SDL] The SDL_mixer library: /usr/lib/x86_64-linux-gnu/libSDL_mixer.so
-- [SDL] The SDL_net library: SDL_NET_LIBRARY-NOTFOUND
CMake Error at ta3d/CMakeLists.txt:181 (message):
  SDL_net not found, SDL_net is required


-- Configuring incomplete, errors occurred!
See also "/home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/CMakeFiles/CMakeOutput.log".
See also "/home/sieuzac/Documents/Compil TA3D/CP8/ta3d/src/CMakeFiles/CMakeError.log".

Donc je vois précisement qu'il y a un probleme avec SDL_net version 1.2. Plus precisement, je suis alais voir le dossier /usr/lib/x86_64-linux-gnu et j'y ai trouvé les fichié suivent:
1) libSDL_image.so, libSDL_image.so.o de meme taille et libSDL_image.a
2) libSDL_mixer.so et libSDL_mixer.so.o de meme taille et libSDL_mixer.a
3) libSDL_net.so.o mais pas libSDL_net.so (d'ou le message d'erreur) ni libSDL_net.a


Voila voila, j'en dit pas plus et j’attends que quelqu'un ce propose de m'aider :)

PS si quelqu'un peu m'aidé car ça fait deux ans que j'aissé de l'instalé et que je n'y arrive jamais :p
Aussi je sais que je n'est pas a metre ce message ic mais dans aide, je n'est eu aucune réponce :p

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests