r2552 tests

You have tested TA3D, share your experience /
Vous avez testé TA3D, venez partager votre expérience
Post Reply
User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

r2552 tests

Post by yoshi314 » Mon Apr 05, 2010 3:46 pm

pretty much everything works fine, and with good performance.

the more serious issue is lack of info on keyboard shortcuts. how do i rotate the camera? i can give some more detailed tests later on. also, there is no info on keyboard shortcuts, nor ability to configure them.

problems :
- i cannot build anything else than laser turrets in final arm missions (standard TA). what the heck?
- on first core prime arm mission i can see the sky texture behind the edge of terrain (default camera setting).
- arm commander walks funny when trying to capture core construction bot (zig-zags), which pretty much walks a straight line (first core prime mission from standard TA)

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: r2552 tests

Post by zuzuf » Mon Apr 05, 2010 9:01 pm

Thank you for reporting.

You can rotate the camera holding your mouse middle button when in free camera mode.

Keyboard shortcuts are difficult to configure, due to OTA design (they're mostly stored into GUI files for everything related to GUI like unit orders - because they are triggered through a menu button).

Build restrictions bug in final arm missions is fixed :)
=>;-D Penguin Powered

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: r2552 tests

Post by yoshi314 » Tue Apr 06, 2010 5:06 pm

coll, running off to test now.

i think left+right (pressed together) should also rotate the camera. on my mouse wheel serves as a middle button.

ok, it works.

one more bug found with current svn (r2554) - trying to order commander to reclaim the antenna unselects the commander (i think it was done with left click, or am i wrong?)

i'll try to reproduce this more accurately

also i saw nanolathe spray, but only when commander was building something to the top-left of his position. that's pretty strange, but i prefer to blame it on testing video drivers.

edit: it also works for making buildings to the north of commander position. weird.

segfault when saving game (only 0 byte file is created)

Code: Select all

./ta3d(_Z17backtrace_handleri+0x21) [0x81e7681]
[0xa7709400]
/lib/libc.so.6(strlen+0x33) [0xa735b4b3]
/lib/libz.so.1(gzputs+0x25) [0xa7631525]
./ta3d() [0x83b16c3]
./ta3d(_ZN4TA3D9save_gameEN4Yuni10StringBaseIcLi128EEEPNS_8GameDataE+0x261) [0x83b19bd]
./ta3d(_ZN4TA3D6Battle7executeEv+0x86ea) [0x8375bf6]
./ta3d(_ZN4TA3D6Battle7ExecuteEPNS_8GameDataE+0x2e) [0x8363c66]
./ta3d(_ZN4TA3D12brief_screenEN4Yuni10StringBaseIcLi128EEEi+0x3152) [0x83d3c8b]
./ta3d(_ZN4TA3D18campaign_main_menuEv+0x1780) [0x83d09fd]
./ta3d(_ZN4TA3D5Menus4Solo16doGoMenuCompaignEv+0x10) [0x839f512]
./ta3d(_ZN4TA3D5Menus4Solo22maySwitchToAnotherMenuEv+0x2f8) [0x839f3b8]
./ta3d(_ZN4TA3D5Menus8Abstract6doLoopEv+0x5a) [0x839a8d8]
./ta3d(_ZN4TA3D5Menus8Abstract9doExecuteEv+0x18) [0x839a90c]
./ta3d(_ZN4TA3D5Menus8Abstract14doGuardExecuteEv+0x18) [0x839a6f2]
./ta3d(_ZN4TA3D5Menus8Abstract7executeEv+0x20) [0x839a654]
./ta3d(_ZN4TA3D5Menus4Solo7ExecuteEv+0x1e) [0x839ee1e]
./ta3d(_ZN4TA3D5Menus8MainMenu12goToMenuSoloEv+0x10) [0x83a7a10]
./ta3d(_ZN4TA3D5Menus8MainMenu22maySwitchToAnotherMenuEv+0x1eb) [0x83a6dcd]
./ta3d(_ZN4TA3D5Menus8Abstract6doLoopEv+0x5a) [0x839a8d8]
./ta3d(_ZN4TA3D5Menus8MainMenu9doExecuteEv+0x18) [0x83a69c0]
./ta3d(_ZN4TA3D5Menus8Abstract14doGuardExecuteEv+0x18) [0x839a6f2]
./ta3d(_ZN4TA3D5Menus8Abstract7executeEv+0x20) [0x839a654]
./ta3d(_ZN4TA3D5Menus8MainMenu7ExecuteEv+0x1e) [0x83a6546]
./ta3d(main+0x172) [0x84088ad]
/lib/libc.so.6(__libc_start_main+0xe6) [0xa72febb6]
./ta3d() [0x81c1231]
An error has occured.
Debugging information have been logged to:
/home/yoshi/.ta3d/log/backtrace.txt
Please report to our forums (http://www.ta3d.org/)
and keep this file, it'll help us debugging.

Code: Select all

[Tue Apr  6 19:24:25 2010][ta3d][error] [shader] Fragment shader: `shaders/map_shadow.frag` failed to compile
[Tue Apr  6 19:24:25 2010][ta3d][error] [shader] Error: undefined function 'abs'
i suppose i can molest mesa (xorg) team with this, or is it a shader bug?

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: r2552 tests

Post by zuzuf » Tue Apr 06, 2010 5:52 pm

This is not a shader bug, the abs function should exist.

Thanks for the stack trace, it'll help find this nasty bug 8)
=>;-D Penguin Powered

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests