Video playback support :)

Everything related to the code /
Tout ce qui touche au code
Post Reply
User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Video playback support :)

Post by zuzuf » Sun Apr 11, 2010 10:21 pm

I've just added video playback support (for intro/transition movies) so now TA3D can play MPEG-1 videos :).

Current SVN code tries to play the 'video/intro.mpg' file when it exists just before loading main menu.

I haven't tested it on windows (SMPEG is not integrated yet into the source tree for win32 build) and I don't know how it works on mac OS but at least it works on Linux :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Video playback support :)

Post by Balthazar » Mon Apr 12, 2010 5:05 am

I suggest to set intro video in the upper part of the first game screen (where intro text showing), so the bottom part will be with the text info - the upper one - will be for the video :P

We can also add video support for loading menu - cyclic play short movies of units that are already done during loading process :P

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Video playback support :)

Post by zuzuf » Mon Apr 12, 2010 5:21 am

It's a bit complex to set up but why not once video module is working everywhere. I like this idea :)
=>;-D Penguin Powered

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests