R2887 - mod units not found anymore.

You have tested TA3D, share your experience /
Vous avez testé TA3D, venez partager votre expérience
Post Reply
Durand
Posts: 74
Joined: Thu Nov 04, 2010 11:13 am

R2887 - mod units not found anymore.

Post by Durand » Mon Feb 28, 2011 6:51 pm

Hi,

For some reason, look like the game don't look for units in the mod folders anymore.
[Mon Feb 28 19:49:23 2011][ta3d][debug] unit 'arm_t1_usi_kbots' not found
Attachments
ta3d.log.zip
(16.67 KiB) Downloaded 429 times

Durand
Posts: 74
Joined: Thu Nov 04, 2010 11:13 am

Re: R2887 - mod units not found anymore.

Post by Durand » Sun Mar 06, 2011 7:23 am

Okay, i found an idea : For some reason, the game, when reading the OBJ file, try to find a file called "mtllib".
[Sun Mar 6 07:51:52 2011][ta3d][debug] [Mesh] Loading `objects3d\arm_t3_veh_hydre.obj`
[Sun Mar 6 07:51:52 2011][ta3d][debug] [VFS] file not found (objects3d/mtllib)
If that's because of this line in the OBJ file :
mtllib arm_t1_def_defender.mtl
Look like the game read mtllib, understand it's the line where the MTL file is noted, and then use the first word on the line as file name.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: R2887 - mod units not found anymore.

Post by zuzuf » Sun Mar 06, 2011 4:38 pm

Interesting I am going to have a closer look at it, thanks.
=>;-D Penguin Powered

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: R2887 - mod units not found anymore.

Post by zuzuf » Fri Mar 18, 2011 8:08 am

Do you have the corresponding "anims//unit_gadget.gaf" files with entries for the missing units (can be directories with GAF structure too) ?
=>;-D Penguin Powered

Durand
Posts: 74
Joined: Thu Nov 04, 2010 11:13 am

Re: R2887 - mod units not found anymore.

Post by Durand » Fri Mar 18, 2011 8:41 am

I never had any anim folder (or gaf file) for this mod.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: R2887 - mod units not found anymore.

Post by zuzuf » Fri Mar 18, 2011 9:47 am

So I found the bug, it should be fixed now :) : TA3D expects a buildpic from anims//unitname_gadget.gaf or the unitpic but it was only checking for the OpenGL texture handle whose creation is delayed until it's needed (now it loads the texture data if it detects it hasn't been done) so it was failing.
=>;-D Penguin Powered

Durand
Posts: 74
Joined: Thu Nov 04, 2010 11:13 am

Re: R2887 - mod units not found anymore.

Post by Durand » Fri Mar 18, 2011 10:44 am

Okay, perfect, thanks.

Post Reply

Who is online

Users browsing this forum: No registered users and 12 guests