Need actualisation - test report from beta 11

You have tested TA3D, share your experience /
Vous avez testé TA3D, venez partager votre expérience
User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Need actualisation - test report from beta 11

Post by Balthazar » Fri Apr 23, 2010 5:25 pm

Yep, on Windows video file required.

I suggest to put any *.mpg video in /video/ folder inside the package, so there`ll be no problems with running :)

Hey! Nice F1 buildpics! Thanks! Core Rapier is my love forever :P I guess I`ll try to create a model or two :P

Here are the founded bugs so far.

1: White maps (with clouds or white smoke fields) are still filled with lava instead of white smoke. Sad.
2: Campaign buildings (that are given from the start) don`t have animation (i.e. taidai generators), but the new ones do have!

3: Many units don`t leave wrecks (Goliath, Maverick, Zeus and so on).
4: If Albatros plane ordered to guard ship - it begin to fly under water!!!
5: Planes fly height must be set to higher values, cause now they are riding over the mountains :P
6: Reclaiming time for ships to reclaim ship wreck is enormous, reclaiming 75M wreck with Constr. ship takes about.... forever?.
7: Desintegrator don`t want to fire anywhere :(
8: Patroling planes don`t attack directly the target they encountered (for example, Brawler), but continues to patrol shooting by the way at enemy.
9: When building ARM SolarPlant game crashes.
Added 10: Instant victory/defeat bug
10. Bounding to land coordinates of left top corner of Selection box is not fixed (i reported this earlier), thus this box is moving with my camera (don`t see a bug here :P- Balthazar)
11. MOVE command for builders is not translated to GUARD action when clicking on allied units
12. In buildings placement mode (to build in stack) right mouse button click should cancel this mode, so i'm able to continue issuing orders like MOVE, GUARD, REPAIR etc.
13. Attack cursor for bombers when mouse is over enemy unit does not represent OTA's cursor for bombers (yes, it is special)
14. Pause music when ESC is pressed?
15. Order commander to move somewhere, and in the meantime change his orders to build something in the middle of the way he was ordered to walk. the commander will build the structure, while walking without moving ;)
16. It is much easier to destroy an enemy unit by targeting the land behind it, compared to targeting it directly (hit rate is still low, but much higher than in case of normal attack).
17. It's nearly impossible to order a construction unit to recycle a large area (e.g. lots burnt trees, on arm mission 6). unit keeps dropping the queue, or something similar happens. it would be nice to be able to pick an order, and just drag across the area to target all suitable objects and add them to the queue
18. Order a commander to attack something, then order him to build something next to his target. the commander will attack and nanolathe at the same time ;) (Funny :P)
19. Commander can get stuck between trees, and even reclaiming is impossible in this situation (wtf?)
20. Ship pathfinding sucks. order a ship to go to the target behind the ship depot - it will keep trying to go through the depot, despite it being busy constructing another unit. (yeah, yeah :))
21. Pressing ESC in "solo" menu quits the game. it's not a crash judging by the output.
22. When reclaiming something small (e.g. a burnt tree) the nanolathe beam is way too wide.
23. Reclaim time for trees/rocks/wrecks is too long.
24. Set Grizvolds music theme to menu screens, in-game it became too annoying because it`s the only track available.

And a suggestion:
Set ingame menu size 2x times smaller. Now it looks huge :P

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Fri Apr 23, 2010 9:07 pm

Bug with /anims/ folder still present. I can`t run game with the /anims/ folder from the latest SVN version. Game loading halts on the Loading GUI function. Logs attached.

And some visual bug found, don`t know exactly how to call it. The metal deposits underwater with some angles have strange reflection above them, see screenshots.
Attachments
1112.JPG
1111.JPG
ta3d.rar
(4.66 KiB) Downloaded 698 times

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Fri Apr 23, 2010 9:55 pm

First and second posts are updated.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sat Apr 24, 2010 2:55 pm

#1 and #2 are fixed.

This anim bug is annoying, there is nothing in the logs :(, I'll send you a debug binary, hopefully we'll get more info :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sat Apr 24, 2010 8:28 pm

zuzuf wrote:#1 and #2 are fixed.

This anim bug is annoying, there is nothing in the logs :(, I'll send you a debug binary, hopefully we'll get more info :)
Got it. Will report back soon :P

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sat Apr 24, 2010 9:22 pm

Here the crash log, i guess because of shaders. Anims folder was not present here.
Attachments
ta3d.rar
(10.13 KiB) Downloaded 706 times

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sat Apr 24, 2010 9:39 pm

I am going to look at those logs :)

Can you try a map with white fog ? (and run reloadShaders() in the game console :D ) I'd like to know if the new shaders work properly :).

PS: #7 should be fixed too now :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sat Apr 24, 2010 9:45 pm

Here the new logs with anims folder but without shaders. After some time of playing - 20-30 sec the game crashed.
Attachments
ta3d2.rar
(23.74 KiB) Downloaded 727 times

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sat Apr 24, 2010 9:51 pm

With anims and shaders game runs fine.

reloadShaders() does nothing. At least i didn`t see the difference. Are they connected with water rendering?

WHite fog bug seems to be fixed, but there are still lava flares flying out the white fog like from lava.

Logs attached.
Attachments
ta3d3.rar
(31.68 KiB) Downloaded 688 times

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sat Apr 24, 2010 10:50 pm

reloadShaders() wasn't meant to change anything in game, just to build all shaders and produce useful logs :D and it's a nice success 8) .

Oops, I had forgotten those lava and waves effects, I've fixed that too :).
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun Apr 25, 2010 9:11 am

New bug added.
First post updated.
When building ARM SolarPlant game crashes.
Attachments
ta3d4.rar
(60.77 KiB) Downloaded 685 times

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sun Apr 25, 2010 11:14 am

Can you reproduce it ? Does it happens without the free data set too ?
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun Apr 25, 2010 7:20 pm

zuzuf wrote:Can you reproduce it ? Does it happens without the free data set too ?
It doesn`t happen without free data set.

But with free data set if i try to build ARM solar - game crashes. And Solar model blueprint looks grey, like the metal extractor - without textures.
Attachments
ta3d5.rar
(83.48 KiB) Downloaded 723 times

slogic
Posts: 75
Joined: Wed Mar 26, 2008 5:23 pm
Location: RF, Bryansk
Contact:

Re: Beta 11 test report

Post by slogic » Mon Apr 26, 2010 5:53 pm

1. Bounding to land coordinates of left top corner of Selection box is not fixed (i reported this earlier), thus this box is moving with my camera
2. MOVE command for builders is not translated to GUARD action when clicking on allied units
3. In unit placement mode (to build) right mouse button click should cancel this mode, so i'm able to continue issuing orders like MOVE, GUARD, REPAIR etc.
4. Attack cursor for bombers when mouse is over enemy unit does not represent OTA's cursor for bombers (yes, it is special)
5. Pause music when ESC is pressed?

PS. For ATI videocrads turn off texture compression in settings. It caused a crash in its driver when game started for me.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Mon Apr 26, 2010 7:26 pm

for #1, there is still the problem of how do we attach the selection box to the map in perspective mode ?

Maybe you should put all the bugs in the same list, it would be easier to keep track of bugs looking at one big list instead of many small ones :).
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Mon Apr 26, 2010 7:48 pm

zuzuf wrote:Maybe you should put all the bugs in the same list, it would be easier to keep track of bugs looking at one big list instead of many small ones :).
Done.

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Tue Apr 27, 2010 6:31 am

First post updated with bugs/suggestions.

slogic
Posts: 75
Joined: Wed Mar 26, 2008 5:23 pm
Location: RF, Bryansk
Contact:

Re: Beta 11 test report

Post by slogic » Wed Apr 28, 2010 9:07 pm

zuzuf wrote:for #1, there is still the problem of how do we attach the selection box to the map in perspective mode ?
Bound it to intersection with land at this point like it is done in Spring.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Wed Apr 28, 2010 9:56 pm

Yeah but it won't really match the selection rectangle on screen ...
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Thu Apr 29, 2010 5:52 am

zuzuf wrote:Yeah but it won't really match the selection rectangle on screen ...
With orthographic projection it will be better :P ? Anyway, don`t see a reason till now why to fix selection box on the ground.
Days when you should select half map of units dragging the rectangle around it have passed long ago.

slogic
Posts: 75
Joined: Wed Mar 26, 2008 5:23 pm
Location: RF, Bryansk
Contact:

Re: Beta 11 test report

Post by slogic » Thu Apr 29, 2010 1:55 pm

zuzuf wrote:Yeah but it won't really match the selection rectangle on screen ...
I feel absolutely no discomfort. Usually player move the cam in horizontal plane and do not change an angle during selection.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Thu Apr 29, 2010 1:59 pm

the problem is due to perspective not preserving on screen geometry when camera is moving, no matter which transformation it involves.
=>;-D Penguin Powered

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sun May 02, 2010 12:57 pm

bugs #11 and #13 are fixed :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun May 02, 2010 1:39 pm

zuzuf wrote:bugs #11 and #13 are fixed :)
Updated :)

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sun May 02, 2010 2:05 pm

Regarding the bug with water reflection, which water quality setting did you use ?
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun May 02, 2010 5:30 pm

zuzuf wrote:Regarding the bug with water reflection, which water quality setting did you use ?
I`ve noticed it on 4 and 5 water quality settings. I guess it`s somehow connected to water relections, since this effect appearing not always, but only at some camera positioning.

Sky reflections are almost absent on water, maybe we should tweak a little water reflections to reflect sky?

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sun May 02, 2010 8:11 pm

I think there may be a bug which renders several things in the reflection image like underwater metal patches which may hide the sky and/or other things and produce those strange effects.
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun May 02, 2010 10:09 pm

Is current 3DMeditor2 supports reflection textures on units?

Buglist updated with the new bugs/suggestions.

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Mon May 03, 2010 8:40 am

pressing ESC in "solo" menu quits the game. it's not a crash judging by the output.

also, when reclaiming something small (e.g. a burnt tree) the nanolathe beam is way too wide.

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Mon May 03, 2010 9:29 am

Updated.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Mon May 03, 2010 10:41 am

Balthazar wrote:Is current 3DMeditor2 supports reflection textures on units?
Yes it does, there is an option to use the last texture as an environment map but it only works with 3DM format.
=>;-D Penguin Powered

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Tue May 04, 2010 10:02 am

when starting some water-based missions there are no units on the map. also, the land is barely visible (black).

i was thinking it was graphics error, but i cannot select any units by dragging , or ctrl+a . also, mission doesn't end too.

i'd like somebody to verify this, before adding to the list.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Tue May 04, 2010 10:15 am

It's probably a bug in the mission script generator.
Which missions did you test ?
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Tue May 04, 2010 1:40 pm

Have no errors on OTA and CC missions. There are must be the one-two maps bugged, not all of the maps. Yeah, can you tell us which map was exactly bugged?

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Tue May 04, 2010 6:56 pm

first map of arm CC mission. just the sea and black terrain. no units at all, even on minimap.

edit: there is something interesting in the log, wait a moment

Code: Select all

[Tue May  4 20:55:03 2010][ta3d][infos] [battle] Loading details texture...
[Tue May  4 20:55:03 2010][ta3d][infos] [battle] Initialising the Fog Of War...
[Tue May  4 20:55:03 2010][ta3d][debug] [battle] Extracting `maps\EXP1AC01.ota`...
[Tue May  4 20:55:03 2010][ta3d][infos] [battle] Loading map informations...
[Tue May  4 20:55:03 2010][ta3d][infos] [battle] Computing walkable areas...
[Tue May  4 20:55:08 2010][ta3d][infos] [paths] walkable areas : 139kb
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\sky-night2.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\mars0.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\day-sky.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\milkyway.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\galaxy.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\hell0.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\nebulae.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\sky-night.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\day-sky2.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\earth0.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] loading sky : sky\hubble.tdf
[Tue May  4 20:55:08 2010][ta3d][debug] [gfx] no sky associated with this map('EXP1AC01') or this planet('water world') found, looking for default skies
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] Loading time: 32.643002 sec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] statistics:
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initPreflight(g) done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTextures() done in 489 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] init3DModels() done in 5280 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initGraphicalFeatures() done in 1468 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initWeapons() done in 903 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initUnits() done in 9104 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initIntermediateCleanup() done in 22 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initEngine() done in 24 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initPlayers() done in 141 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initRestrictions() done in 14 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initGUI() done in 3608 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheMap() done in 6991 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheSky() done in 4435 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheSun() done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initAllTextures() done in 78 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheCamera() done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheWind() done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheFog() done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initParticules() done in 66 msec.
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] initTheWater() done in 0 msec.
[Tue May  4 20:55:12 2010][ta3d][error] [script::lua] /mnt/data2/src/ta3d-svn/src/ta3d/src/scripts/lua.thread.cpp l.274
[Tue May  4 20:55:12 2010][ta3d][error] [script::lua] [string "scripts/game/__campaign_script.lua"]:935: main function has more than 200 local variables
[Tue May  4 20:55:12 2010][ta3d][error] [script::lua] 35435 -> 10
[Tue May  4 20:55:12 2010][ta3d][error] local DEG2RAD = 0.017453292519943295
local RAD2DEG = 57.29577951308232

local DEG2TA = 182.04444444444445
local TA2DEG = 0.0054931640625

local RAD2TA = 20860.756700940907
local TA2RAD = 0.000047936899621426287

local Builder = -3
local CanAttack = -2

local yield = coroutine.yield

local function sleep(delay)
    yield(delay, 1)
end

local function wait()
    yield(0, 2)
end

local function end_thread()
    yield(0, 4)
end

local function set_signal_mask(sig)
    yield(sig, 3)
end

local function vector()
    local vec = {x=0, y=0, z=0}
    return setmetatable(vec, __vector_metatable)
end

-- conservative functions that don't overwrite "permanent" objects but produce a temporary one
local function __vec_add(v0,v1)
    return setmetatable({x=v0.x + v1.x, y=v0.y + v1.y, z=v0.z + v1.z}, __fast_vector_metatable)
end

local function __vec_sub(v0,v1)
    return setmetatable({x=v0.x - v1.x, y=v0.y - v1.y, z=v0.z - v1.z}, __fast_vector_metatable)
end

local function __vec_mul(m,v)
    return setmetatable({x=m * v.x, y=m * v.y, z=m * v.z}, __fast_vector_metatable)
end

local function __vec_dot(v0,v1)
    return v0.x * v1.x + v0.y * v1.y + v0.z * v1.z
end

local function __vec_cross(v0,v1)
    return setmetatable({x=v0.y * v1.z - v0.z * v1.y, y=v0.z * v1.x - v0.x * v1.z, z=v0.x * v1.y - v0.y * v1.x}, __fast_vector_metatable)
end

-- convert a temporary object into a "permanent" one
local function fix_vector(v)
    return setmetatable(v, __vector_metatable)
end

-- use fast functions for temporary objects (we don't need to create new tables since we already have one we won't reuse)
local function __fast_vec_add(v0,v1)
    v0.x = v0.x + v1.x
    v0.y = v0.y + v1.y
    v0.z = v0.z + v1.z
    return v0
end

local function __fast_vec_sub(v0,v1)
    v0.x = v0.x - v1.x
    v0.y = v0.y - v1.y
    v0.z = v0.z - v1.z
    return v0
end

local function __fast_vec_mul(m,v)
    v.x = m * v.x
    v.y = m * v.y
    v.z = m * v.z
    return v
end

__vector_metatable = {__add=__vec_add, __sub=__vec_sub, __mul=__vec_mul, __mod=__vec_dot, __pow=__vec_cross}
__fast_vector_metatable = {__add=__fast_vec_add, __sub=__fast_vec_sub, __mul=__fast_vec_mul, __mod=__vec_dot, __pow=__vec_cross}

-- normalize v, modifies the content of v
local function normalize(v)
    local l = 1.0 / math.sqrt( v % v )
    v.x = l * v.x
    v.y = l * v.y
    v.z = l * v.z
    return v
end

-- returns the normalized version of v, doesn't change v
local function normalized(v)
    local l = 1.0 / math.sqrt( v % v )
    local tmp = vector()
    tmp.x = l * v.x
    tmp.y = l * v.y
    tmp.z = l * v.z
    return tmp
end

-- returns the angle between 2 vectors
local function vangle(v1, v2)
    return math.acos((v1 % v2) / math.sqrt( (v1 % v1) * (v2 % v2) )) * RAD2DEG
end

local game_signal = coroutine.yield

local function set_cam_mode( mode )
    if mode == CAM_NORMAL_MODE then
        game_signal( SIGNAL_CAM_DEF )
    else
        if mode == CAM_FREE_MODE then
            game_signal( SIGNAL_FREECAM )
        end
    end
end
local function piece(this, ...)
    __piece_list = {...}
    if #__piece_list == 0 then
        return
    end
    for i = 1, #__piece_list do
        this[__piece_list[i]] = i - 1
    end
    this["__piece_list"] = __piece_list
end

__units = {}

local function createUnitScript(name)
        _G["__name"] = name
        local script = {name=name}
        script.piece = piece
        script.yield = coroutine.yield
        script.is_turning = is_turning
        script.is_moving = is_moving
        script.wait_for_turn =  function (this, obj, axis)
                                                                while this:is_turning(obj, axis) do
                                                                        this.yield()
                                                                end
                                                        end
        script.wait_for_move =  function (this, obj, axis)
                                                                while this:is_moving(obj, axis) do
                                                                        this.yield()
                                                                end
                                                        end

        script.move = move
        script.explode = explode
        script.turn = turn
        script.get_value_from_port = get_value_from_port
        script.spin = spin
        script.stop_spin = stop_spin
        script.show = show
        script.hide = hide
        script.emit_sfx = emit_sfx
        script.move_piece_now = move_piece_now
        script.turn_piece_now = turn_piece_now
        script.get = get
        script.set
[Tue May  4 20:55:12 2010][ta3d][infos] [battle] *** The game has started - Good luck Commander ! ***
[Tue May  4 20:55:12 2010][ta3d][infos] [AI] Started for player 1
[Tue May  4 20:55:25 2010][ta3d][infos] [battle] *** The game is over Commander ***
[Tue May  4 20:55:25 2010][ta3d][infos] [AI] Stopping for player 1...

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Tue May 04, 2010 8:51 pm

Well, looks like some troubles with lua scripts. Are you using Linux? (Cause on Win XP no such bug noticed).

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Tue May 04, 2010 9:06 pm

You don't see this bug on windows because last beta is not affected ... this is due to something I changed recently. I wasn't aware of this limitation :(

PS: this should be fixed now
=>;-D Penguin Powered

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Wed May 05, 2010 5:00 am

Balthazar wrote:Well, looks like some troubles with lua scripts. Are you using Linux? (Cause on Win XP no such bug noticed).
yes. and i must say i'm glad i am, because it would pass unnoticed ;)


tested, and seems to be ok now. i can start the mentioned mission, the water and land looks normal too. i'll have to test some more now.

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Wed May 05, 2010 4:38 pm

starting and exiting arm CC mission 1 few times in a row results in a crash

1st run - high water quality, normal shadow quality
2nd run - normal water quality, normal shadow quality
3nd run - normal water quality, shadows off

(not sure if it matters)

Code: Select all

Obtained 24 stack frames.
./ta3d(_Z17backtrace_handleri+0x21) [0x81ed68d]
[0xa7883400]
./ta3d(_ZN4TA3D12INGAME_UNITS4pickERNS_6CameraE+0x34f) [0x82ca91b]
./ta3d(_ZN4TA3D6Battle7executeEv+0x612d) [0x8386d75]
./ta3d(_ZN4TA3D6Battle7ExecuteEPNS_8GameDataE+0x2e) [0x8376aca]
./ta3d(_ZN4TA3D12brief_screenEN4Yuni10StringBaseIcLi128EEEi+0x3152) [0x83e8f58]
./ta3d(_ZN4TA3D18campaign_main_menuEv+0x1780) [0x83e5cca]
./ta3d(_ZN4TA3D5Menus4Solo16doGoMenuCompaignEv+0x10) [0x83b38d2]
./ta3d(_ZN4TA3D5Menus4Solo22maySwitchToAnotherMenuEv+0x2f8) [0x83b3770]
./ta3d(_ZN4TA3D5Menus8Abstract6doLoopEv+0x5a) [0x83ae5d0]
./ta3d(_ZN4TA3D5Menus8Abstract9doExecuteEv+0x18) [0x83ae604]
./ta3d(_ZN4TA3D5Menus8Abstract14doGuardExecuteEv+0x18) [0x83ae3ea]
./ta3d(_ZN4TA3D5Menus8Abstract7executeEv+0x20) [0x83ae34c]
./ta3d(_ZN4TA3D5Menus4Solo7ExecuteEv+0x1e) [0x83b31d6]
./ta3d(_ZN4TA3D5Menus8MainMenu12goToMenuSoloEv+0x10) [0x83bc64c]
./ta3d(_ZN4TA3D5Menus8MainMenu22maySwitchToAnotherMenuEv+0x1eb) [0x83bba09]
./ta3d(_ZN4TA3D5Menus8Abstract6doLoopEv+0x5a) [0x83ae5d0]
./ta3d(_ZN4TA3D5Menus8MainMenu9doExecuteEv+0x18) [0x83bb5fc]
./ta3d(_ZN4TA3D5Menus8Abstract14doGuardExecuteEv+0x18) [0x83ae3ea]
./ta3d(_ZN4TA3D5Menus8Abstract7executeEv+0x20) [0x83ae34c]
./ta3d(_ZN4TA3D5Menus8MainMenu7ExecuteEv+0x1e) [0x83bb116]
./ta3d(main+0x172) [0x841f37d]
/lib/libc.so.6(__libc_start_main+0xe6) [0xa741abb6]
./ta3d() [0x81c57c1]
An error has occured.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Wed May 05, 2010 4:57 pm

Great, the logs precisely tell where it crashed (it's in a not too big function). I should be able to fix that when I have time :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Thu May 06, 2010 5:03 am

zuzuf wrote:Great, the logs precisely tell where it crashed (it's in a not too big function). I should be able to fix that when I have time :)
Yeah, there is such thing like random crash on loading if several games was played without exiting ta3d. Maybe it`s the cause :P

slogic
Posts: 75
Joined: Wed Mar 26, 2008 5:23 pm
Location: RF, Bryansk
Contact:

Re: Beta 11 test report

Post by slogic » Thu May 06, 2010 4:46 pm

18. Order a commander to attack something, then order him to build something next to his target. the commander will attack and nanolathe at the same time (Funny )
I don't see a problem here. It is a nice and logic extension to OTA. Commander has two arms with nanolate spray & lazer. You issued two actions and if distance allows why no to make two things simultaneously? I hope zuzuf will leave this. Also you can order attack and reclaim on the same unit to speed up its death (without using D-Gun) which is cool.

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Thu May 06, 2010 5:49 pm

I suppose the bug is not in this exactly, the bug is in Comm facing. I suppose he can attack units by turning 108 deg to them, while nanolathing something that is after his back. But for me - i do not see a problem here :P Why unit can`t nanolathe something facing the opposite direction? It`s a future :P

DOT
Posts: 151
Joined: Sat Sep 19, 2009 11:56 am

Re: Beta 11 test report

Post by DOT » Thu May 06, 2010 6:42 pm

+1 for Pause music in ESC Menu it is annoying :S

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Fri May 07, 2010 6:08 am

DOT wrote:+1 for Pause music in ESC Menu it is annoying :S
Updated.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Fri May 07, 2010 9:49 pm

The nanolathe bug is not due to the commander doing 2 things at the same time ... this is not possible with current design, it's probably a missing event to stop nanolathe animation.
=>;-D Penguin Powered

User avatar
yoshi314
Posts: 54
Joined: Sat Feb 23, 2008 3:30 pm
Location: PL
Contact:

Re: Beta 11 test report

Post by yoshi314 » Mon May 10, 2010 10:09 am

I don't see a problem here. It is a nice and logic extension to OTA. Commander has two arms with nanolate spray & lazer. You issued two actions and if distance allows why no to make two things simultaneously? I hope zuzuf will leave this. Also you can order attack and reclaim on the same unit to speed up its death (without using D-Gun) which is cool.
i thought the goal of ta3d was to have "same gameplay, better graphics". but maybe it's just my imagination ;)

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Tue May 11, 2010 11:08 am

You're right it's still the goal that's why current design doesn't allow this, it's just a bug.
=>;-D Penguin Powered

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: Beta 11 test report

Post by zuzuf » Sun May 16, 2010 1:06 pm

#14, #15 and #21 are fixed
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: Beta 11 test report

Post by Balthazar » Sun May 16, 2010 7:37 pm

Updated :P

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests