0.5.4: CMake can't find required libs

You have a problem with TA3D, it doesn't run or it crashes...
/
Vous avez un problème avec TA3D, il ne se lance pas ou plante...
Post Reply
XChesser
Posts: 10
Joined: Tue Aug 24, 2010 10:49 pm

0.5.4: CMake can't find required libs

Post by XChesser » Wed Aug 25, 2010 11:49 am

I've tried to cmake ta3d 0.5.4 but got an error:

Code: Select all

CMake Error at CMakeLists.txt:184 (message):
  AllegroGL >= 0.4.1 is required
AllegroGL now is part of Allegro. I thought maybe that's the reason why cmake can't find it and commented some lines in CMakeLists.txt:

Code: Select all

#    IF( NOT VAR_LIB_ALLEG_GL )
#	message( FATAL_ERROR "AllegroGL >= 0.4.1 is required" )
#    ENDIF( NOT VAR_LIB_ALLEG_GL )
After that I got:

Code: Select all

CMake Error at src/CMakeLists.txt:302 (message):
  FMODex is required, please install FMODex
I have both Allegro and FMODex installed but CMake can't find them in any reason.

Here is some info:

Code: Select all

xchesser@Sabayon ~/Закачки/ta3d $ allegro-config --version
4.4.1
xchesser@Sabayon ~/Закачки/ta3d $ cmake --version
cmake version 2.8.1
xchesser@Sabayon ~/Закачки/ta3d $ ls /opt/fmodex/api/lib/ -l
итого 6880
-rwxr-xr-x 1 root root 1397036 Июл  3  2009 libfmodex-4.26.00.so
-rwxr-xr-x 1 root root 1446188 Июл  3  2009 libfmodexL-4.26.00.so
lrwxrwxrwx 1 root root      21 Авг 25 15:19 libfmodexL.so -> libfmodexL.so.4.26.00
lrwxrwxrwx 1 root root      21 Авг 25 15:19 libfmodexL.so.4 -> libfmodexL.so.4.26.00
-rwxr-xr-x 1 root root 1446188 Авг 21  2009 libfmodexL.so.4.26.00
-rwxr-xr-x 1 root root  669424 Авг 21  2009 libfmodexp-4.26.00.so
lrwxrwxrwx 1 root root      21 Авг 25 15:19 libfmodexp.so -> libfmodexp.so.4.26.00
lrwxrwxrwx 1 root root      21 Авг 25 15:19 libfmodexp.so.4 -> libfmodexp.so.4.26.00
-rwxr-xr-x 1 root root  669424 Авг 21  2009 libfmodexp.so.4.26.00
lrwxrwxrwx 1 root root      20 Авг 25 15:19 libfmodex.so -> libfmodex.so.4.26.00
lrwxrwxrwx 1 root root      20 Авг 25 15:19 libfmodex.so.4 -> libfmodex.so.4.26.00
-rwxr-xr-x 1 root root 1397036 Авг 21  2009 libfmodex.so.4.26.00
xchesser@Sabayon ~/Закачки/ta3d $ echo $LDPATH
/opt/fmodex/api/lib
I've attached full console output for the first case (untouched CMakeLists.txt).
Any ideas?
Attachments
cmake.log.bz2
(703 Bytes) Downloaded 224 times

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: 0.5.4: CMake can't find required libs

Post by zuzuf » Sun Aug 29, 2010 8:24 pm

TA3D 0.5.x has been tested with Allegro up to version 4.2.x. Several libs like AllegroGL have been merged into newer versions of Allegro, I've not run much tests with these versions but I doubt TA3D is compatible with them, you should try the 0.6 branch which is based on SDL.
=>;-D Penguin Powered

XChesser
Posts: 10
Joined: Tue Aug 24, 2010 10:49 pm

Re: 0.5.4: CMake can't find required libs

Post by XChesser » Tue Aug 31, 2010 11:10 pm

OK :)
To tell the truth I decided to try stable 0.5.4 after the fail with dev version. Well... so, let's try to solve the problem with r2669 :D

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests