TA3D 0.6 beta 2 for windows

title is self explanatory / le titre est explicite non ?
Post Reply
User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

TA3D 0.6 beta 2 for windows

Post by zuzuf » Tue Dec 15, 2009 11:54 am

I've fixed several bugs in pathfinder and pathfollowing code, reduced pathfinder complexity by adding checks to prevent the path search to go somewhere there is obviously no interest to go and a few other minor bugs.
Also the long loading time due to some unit code is fixed so you won't have to wait hours before game starts 8)

I don't know how this beta 2 will run on windows (I still have a problem with OpenGL in my virtual machine, so I have no hardware acceleration to test it in game :( but I know it loads fine and much faster than beta 1).

As usual you'll find the package there:
ftp://downloads.ta3d.org/binaries/windows/dev/0.6/

NB: pathfinding works but after some time ground units still refuse to move for unknown reason. I tested a long game against AI and I must say the new algorithm is efficient making waves of enemies reach your base :)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: TA3D 0.8 beta 2 for windows

Post by Balthazar » Tue Dec 15, 2009 4:21 pm

Hehe :P Let`s see how it`ll work :D

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: TA3D 0.8 beta 2 for windows

Post by Balthazar » Tue Dec 15, 2009 4:39 pm

Fix the name of the thread - 0.6 beta 2.

After loading process game just close console and ta3d window. Without errors or anything. Just close.
Attachments
ta3d.zip
(2.61 KiB) Downloaded 392 times

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by zuzuf » Tue Dec 15, 2009 4:58 pm

ooops.

Code: Select all

[Tue Dec 15 19:29:35 2009][ta3d][infos] [battle] initUnits() done in 24882 msec.
This is really odd :shock: , it's 23s more than what I get in debug mode and the binary I made for beta 2 is optimized.

I have no idea what can be responsible for such a long loading time, I'll definitely need to see this on a real windows in order to solve the problem. I'll see that this week end (I won't have access to a windows machine with required dev tools before the WE).
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by Balthazar » Tue Dec 15, 2009 5:26 pm

Ok, take your time :P

xpoy
Posts: 669
Joined: Mon Sep 22, 2008 3:55 am

Re: TA3D 0.6 beta 2 for windows

Post by xpoy » Tue Dec 15, 2009 6:03 pm

GET IT
OMG OMG

Manoa
Posts: 3
Joined: Wed Aug 12, 2009 10:01 pm

Re: TA3D 0.6 beta 2 for windows

Post by Manoa » Mon Dec 21, 2009 5:36 pm

some windows tests:
loading time (cached):
[Thu Dec 17 13:44:23 2009][ta3d][infos] [battle] Preparing a new battle...
[Thu Dec 17 13:46:05 2009][ta3d][infos] [battle] *** The game has started - Good luck Commander ! ***

bugs:
campaign mode: same bugs as in beta 1 (stuck in loading screen)
skirmish: freeze in "Welcome" immediatly after loading (there seems to be some initial map movement but it too fast to do anything with it)

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by zuzuf » Mon Dec 21, 2009 10:55 pm

Yeah that's the same bug :(. This one is driving my crazy :cry:
=>;-D Penguin Powered

milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by milipili » Tue Dec 22, 2009 9:01 am

Sorry about that but, could you make a summary about the bugs on Windows to take a glance ? Which is already resolved ? Which is not ?
- campaign mode: same bugs as in beta 1 (stuck in loading screen)
- skirmish: freeze in "Welcome" immediatly after loading (there seems to be some initial map movement but it too fast to do anything with it) (related with #120 ? http://trac.ta3d.org/ticket/120)
- slow loading of units (24s on some computer)

Perhaps we should update and use the trac tickets more often to have in the same place all issues and their comments.
Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by zuzuf » Tue Dec 22, 2009 2:23 pm

The long loading time for units bug is solved now, what isn't is the random crash at game start (can be at end of loading or a few seconds later) :cry:
=>;-D Penguin Powered

DOT
Posts: 151
Joined: Sat Sep 19, 2009 11:56 am

Re: TA3D 0.6 beta 2 for windows

Post by DOT » Sat Dec 26, 2009 10:10 pm

Hmm on me it is different

the last time i wanted to play TA3D .6 Beta 2

the loading was a bit slow on units but it dint toked too long


and immediately after it got loaded there is a Commander and a Big and Fat a word "Welcome" and it had freeze right there
but no Crashes weird might be Units related


http://pastebin.com/m3d41d989 stderr.txt
http://pastebin.com/mdc1cac8 stdout.txt



Edit: i am not Allowed to attach *.txt files?! O_o and it refuses zip files "Sorry, the board attachment quota has been reached." what does that mean?

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Re: TA3D 0.6 beta 2 for windows

Post by zuzuf » Sat Dec 26, 2009 10:33 pm

attachment quota is set to 5MB for all forums and there were a few unused attachments I've just removed.
=>;-D Penguin Powered

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests