MultiTexturing / Windows / OpenGL VMWare

Everything related to the code /
Tout ce qui touche au code
Post Reply
milipili
Posts: 545
Joined: Thu Nov 02, 2006 8:52 am
Location: Paris (France)
Contact:

MultiTexturing / Windows / OpenGL VMWare

Post by milipili » Thu Jun 19, 2008 1:07 pm

Hi !
I make my branch compiles on Windows (via MinGW) but 3dmeditor.exe raises a SegV due to function named glActiveTextureARB() (for example when importing a 3do file). In the file glfunc.cpp I can see a global variable MultiTexturing, which is equals to `false`.

My Windows is running from a VMWare. As far I know DirectX 9 is fully supported but not really OpenGL, so it may be the cause.

How should I properly disable all calls to this function ?
In fact what is the common way you already use to do it ? (it seems it should be if (MultiTexturing) {})
Damien Gerard
Ta3d & Yuni Developer

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Fri Jun 20, 2008 2:26 pm

just set MultiTexturing to false after initializing OpenGL extensions (otherwise it'll set it back to true). Beware that this will make shaded water rendering impossible.

Also check if glActiveTextureARB == NULL when you call it. If it's the case then may be I forgot to get its address at initialization time (it's not required on Linux but on some platforms it is).

I think I never tested TA3D on a platform that doesn't support multi texturing so it may not work without this extension because it uses calls to related functions a bit everywhere.
=>;-D Penguin Powered

Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests