TA3D 0.4.2 TEST 9

Everything related to the code /
Tout ce qui touche au code
Post Reply
User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

TA3D 0.4.2 TEST 9

Post by zuzuf » Sun Feb 03, 2008 3:39 pm

Ok, new test release :)

it brings bug fixes as usual (thread safety bugs, ...), and also some new features, here is the complete list of changes:
* improved fire effect
* added new trees ( 4 different trees in real 3D ! )
* removed ta3d.hpi since it was referencing old trees and is read after the real objects3d dir, so it's not used here
* skin suffix convention replaced by a prefix convention (better since files get shorted correctly in you file browser :P )
* when current mod is changed in config menu, the sound_manager is reloaded (deleted then allocated again) in order to get proper sounds
* small bug fixe : planes no longer want to land when they have something better to do
* improved buildpic support to support TAWP menus and big/small buildpics
* fixed factories refusing to build something when they've been previously ordered to stop something
* some bug fixes in 3DMEditor code
* usual thread safety bug fixes

download it there:
TA3D 0.4.2 TEST 9
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sun Feb 03, 2008 5:11 pm

And here I am again to save the day :D :D :D Gonna test this thing for sure :)

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sun Feb 03, 2008 7:12 pm

Yeah! That`s the way the things should go!!! Thanks Zuzuf! Nice buildmenu, big buildpics are kinda pretty. All seems work nice, pathfinding works smooth and didn`t spawn errors.

I`ve tested it also with TAWP and notice the same bug as before - amount of damage of different weapons is 100 points, no matter what kind of weapon it is. Just missiles have different damage. Yeah, kinda strange, isn`t it?

Vechicle factories can still stuck when starting build.

Here`s bug with building animation - should be like solar panel.
And bug with advanced radar tower

More testing will be soon.

Image

Image

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sun Feb 03, 2008 7:37 pm

Yeah, I noticed a few animation bugs when testing the new build menu code, but TAWP seems to use advanced scripting which hasn't been much tested and debugged. I think it's a script related problem due to some errors in the implementation of some not often used functions.
=>;-D Penguin Powered

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests