TA3D 0.4.2 TEST 8

Everything related to the code /
Tout ce qui touche au code
Post Reply
User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

TA3D 0.4.2 TEST 8

Post by zuzuf » Sat Jan 19, 2008 8:51 pm

so, what's in the package ?

new features :D !!

* new skin (menu backgrounds for now, still work in progress)
* support for 24/32 bits GAF (TA3D's own extension to GAF format)
* a few bug fixes on win32 build

download it here:
TA3D 0.4.2 TEST 8

PS: it has been released early to allow fast debugging of 24/32 bits GAF support because those GAF aren't compatible with TA and if changes have to be made then compatibility might be lost with current implementation of those GAF.
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Wed Jan 23, 2008 11:24 am

Guys, i`ve got some really busy time last week. I`ve got promoted and kinda got a plenty of stuff to arrange, so don`t be angry if I`ll be not very helpfull for some time :D

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Wed Jan 23, 2008 12:05 pm

We're all busy, and have plenty of work and things to do, so we understand :wink: .

I've played TA3D, a game against 5 AIs, it ran smoothly without crashing or noticeable bugs until the end :D !! It's still the TEST 8 code since I didn't have much time to work on it.

I think current code is stable enough for release, however we have to finish a few things before releasing 0.4.2 :
_the new skin must be ready in order not to give an impression of unfinished thing
_documentation must be updated (lots of things changed since 0.4.1)
_add new tree models (4 nice tree models :) )
_test and debug the GAF 24/32bits code even if we don't put any of those new GAF in the 0.4.2 package (to preserve compatibility if we decide to make some changes to this code...)
_...

and as usual testing before releasing, so we can fix annoying and visible bugs.
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sun Jan 27, 2008 7:48 am

Yeah, the stability of this test release is awesome. I`ll try to update documentation in a few days :)

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sun Jan 27, 2008 1:32 pm

ok, I'll try to add support for big build pics. But I won't release anything today since I was very busy this week to make changes to the code (only small bug fixes and testing some new trees).
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sat Feb 02, 2008 8:20 am

Here`s it is :) I`ve finally got it again :)

Res. 1280x1024x32, shadows - on, water quality - very high.

After next re-run bug dissapeared.

Image

Image

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sat Feb 02, 2008 10:56 am

I forgot to add - this bug only occurs after NEW ta3d installation.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sat Feb 02, 2008 12:34 pm

hm, that's really strange ... since you have an ATI card the texture cache is disabled so it cannot be the source of the problem. And you said shadows were on but there aren't drawn ...

Did you manage to reproduce it on non water maps ?
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sat Feb 02, 2008 2:47 pm

No. I can`t reproduce it after the first one run of newly installed game. I don`t think that it somehow connected to water, since the same run of the same map doesn`t bring the bug.

Also - new installation doesn`t bring this bug for sure. I`ve tryed several re-installation, but bug was gone.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Sat Feb 02, 2008 5:30 pm

what if you clear the cache dir ? (beware it's huge)
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Sat Feb 02, 2008 6:25 pm

Cleaning of cache dir doesn`t bring the bug back. Only full reinstall and not always :)

User avatar
AF
Administrateur - Site Admin
Posts: 139
Joined: Thu Dec 28, 2006 8:19 pm
Location: NW UK
Contact:

Post by AF » Wed Feb 06, 2008 9:38 am

perhaps it is similar to the spring bug that looks a little related?

In spring under windows XP if you alt tab while it's loading you end up with distorted graphics, garbled trees, windows logos in the sky, title bars over units, webpages on the terrain etc...

Doesn't affect Vista as they changed the graphics setup to prevent this

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Wed Feb 06, 2008 6:46 pm

Who knows, but I didn`t alt-tab the ta3d when got this bug.

User avatar
zuzuf
Administrateur - Site Admin
Posts: 3281
Joined: Mon Oct 30, 2006 8:49 pm
Location: Toulouse, France
Contact:

Post by zuzuf » Wed Feb 06, 2008 10:27 pm

what happens if you try to start TA3D in win9x/me/2000 compatibility mode ?
=>;-D Penguin Powered

User avatar
Balthazar
Moderator
Posts: 2055
Joined: Wed Nov 01, 2006 4:31 pm
Location: Russian Federation
Contact:

Post by Balthazar » Fri Feb 08, 2008 2:07 pm

As I mention above - I can`t get this bug when I need - it`s very random. I`ve run several times TA3D in compatibility mode and bug was not there, but it doesn`t means that compatibility mode related somehow.

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests